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What is MissionMan?



MissionMan is a tool used to create or alter missions for multi-player HomeworldTM games. By using it, you can create an entirely new mission or alter an already existing one. This lets you customize your own games.



What are Missions?



Missions are levels of play in HomeworldTM. All missions take place in the universe. The universe size is determined by x, y and z sizes in space. The origin of the universe is always set to zero, zero, zero. All play must take place inside the universe. You can place objects and resources outside the universe but you will not be able to access them when you are playing. In the missions we have already created, we sometimes use asteroids and dust clouds as decoration in space. When you create a new mission, the universe size has already been set, but you may change it if you wish. For visual aid, we have added a world sphere of the same size as the universe. This allows you to check if the objects and resources you are placing are within the universe or not.



How to Create a New Mission

Creating a new mission is easy. Simply click on File, then Create, type a new folder name, then click Save, and MissionMan will open a new, blank mission template in that folder. A new mission is composed of a universe containing two MissionSpheres, (one for each player) and a ResourceSphere. The MissionSpheres are where you place a mothership and other ships for each player. There is one ResourceSphere in each mission. This is where all of the resources are located. You can customize the blank mission template by adding more ships to the MissionSpheres and more resources to the ResourceSphere. Most objects have properties and attributes that can be changed as well. If you want more than two players, you will need to create additional MissionSpheres. Steps one through three will further explain how to perform these operations.



�Basic Controls

At the top of the screen you will find a menu with some basic functions: file, edit, view, tools, window and help. There are keyboard shortcuts for most commands.



File



Create�Creates a new mission��Open�Opens an existing mission��Close�Closes a mission��Generate�Generates the game data for a mission��Exit�Exits MissionMan��

Edit



Undo�Undoes the last operation performed��Properties�Shows a dialog box that allows you to change the currently selected objects/attributes properties��Find�Finds an object by focusing the views on it��New�Adds new objects/attributes to the currently selected object��Duplicate�Duplicates the currently selected objects/attributes��Delete�Deletes the currently selected objects/attributes��Cut�Cuts the currently selected objects/attributes��Copy�Copies the currently selected objects/attributes��Paste�Pastes the cut/coped objects/attributes into the currently selected object��

View



Tree�Shows a hierarchical list of all the objects/attributes in a mission��List�Shows a list of all the attributes for the currently selected��Graphics�Shows a drop down menu to select which of the Camera, Top, Side and Front views are currently visible��Table�Shows a drop-down menu to select which of the Mission, Level, Object and Attribute dialog boxes are currently visible, including the Layers dialog box��Refresh�Refreshes all views, windows and dialog boxes currently visible��

Tools



Toolbar�Toggles the toolbar on/off��Status Bar�Toggles the status bar on/off��Snap Grid�Toggles the snap-to-grid feature on/off, based on the current MissionMan settings��Snap Angle�Toggles the snap-to-angle feature on/off, based on the current MissionMan settings��Free Object Scale�Toggles the object scale feature between synchronized/independent mode��Free Camera�Toggles camera eye & focus placement between synchronized/independent mode��Find Cursor�Finds the placement cursor by focusing the views on it��Find Origin�Finds the universe origin by focusing the views on it��Options�Shows a dialog box that allows you to change MissionMan settings��

Window

The Window menu allows you to perform all standard windows placement operations. You can select the layout of all the views between:



Cascade 

Tile Horizontal

Tile Vertical

Arrange Icons

Default layout (reloads the default MissionMan windows placement)

Help

The Help menu allows you access the About dialog box or the Help file.



Mouse commands and keyboard shortcuts:



Front/Side/Top View Commands

�Left mouse button�Right mouse button�Both mouse buttons��No key�New selection�Menu���Shift key�Move (pan) view��Zoom view��Ctrl key�Highlights selection�Place camera���Shift + ctrl key�Place cursor����Alt key�Move object�Rotate object�Scale object��

Camera Commands

�Left mouse button�Right mouse button�Both mouse buttons��No key�Move (pan) camera�Rotate camera�Zoom camera��Shift key�Move (pan) camera�Rotate camera�Zoom camera��Ctrl key�Move (pan) camera�Rotate camera�Zoom camera��Shift + ctrl key�Move (pan) camera�Rotate camera�Zoom camera��Alt key�Move (pan) camera�Rotate camera�Zoom camera��

Shortcuts

* (Tree)�Expand��- (Tree)�Collapse��+ (View/Camera)�Zoom In��- (View/ Camera)�Zoom Out��Alt – Backspace�Undo��Ctrl – C�Copy��Ctrl – D�Duplicate��Ctrl – F�Find (focus)��Ctrl – G�Generate��Ctrl – L�Layers��Ctrl – N�New��Ctrl- O�Open��Ctrl – P�Options��Ctrl – V�Paste��Ctrl – X�Cut��Shift – F1�Grid snap (toggle)��Shift – F2�Angle snap (toggle)��Shift – F3�Free object scale��Shift – F5�Free camera (toggle)��Del�Delete��Enter�Properties��Esc�Cancel��F1�Help��F5�Refresh��



Step One – Creating a New Mission



To create a new mission:

click on File

click on Create in the menu

type a folder name

click on Save



To open an existing mission:

click on File

click on Open in the menu

select a mission from one of the folders

click on Open



New missions will automatically contain two MissionSpheres and a ResourceSphere. These are the basic elements required for a mission to work in HomeworldTM. When you create a new mission, MissionMan also automatically creates some default attributes for the mission. You may change these attributes to further customize your game:



Lighting

Background

smZoomMax (sets the maximum zoom range for the sensors manager)

smZoomMin (sets the minimum zoom range for the sensors manager)

smInitialDistance

smUniverseSizeX (sets the width of the universe)

smUniverseSizeY (sets the height of the universe)

smUniverseSizeZ (sets the depth of the universe)

ExcludeShips (sets which ships will not be used in a mission)

IncludeShips (sets which ships will be used in a mission)

ExcludeAsteroid (sets which asteroid will not be used in a mission)

IncludeAsteroid (sets which asteroids will be used in a mission)

ExcludeDerelict (sets which derelicts will not be used in a mission)

IncludeDerelict (sets which derelicts will be used in a mission)

BaseColor (sets the base color of ships)

StripColor (sets the stripe colors of ships)

AvailableColorSchemes (sets the colors available for ships)

SongNumber (sets which song will be played in a mission)



Note: The more objects/attributes contained in your mission, the more memory used. You can save memory and run HomeworldTM faster by excluding unused ships, asteroids and derelicts.





Layers let you control the amount of information that is visible in MissionMAn at one time. Layers can be turned on or off and color coordinated. For example, you can create a world layer, a resource layer and a ship layer, using different colors. There are no limits to the number of layers that you create.



Step Two – Defining a MissionSphere



The MissionSphere contains the player's ships. A new mission will automatically include the Mothership. MissionSpheres must be numbered from zero to seven, allowing up to eight simultaneous players. The position of the Mothership determines the player’s starting point in the game. 

To Add New Ships to Your Fleet:

position the placement cursor in the Top, Side and Front views to the desired position in the universe

select the appropriate MissionSphere in the tree view

click on Edit and click on New in the menu

select Ship from the Type drop-down list at the top of the object properties dialog box

select a ship from the Name drop-down list; R1 ships must be placed in R1 MissionSpheres, R2 ships in R2 MissionSpheres etc... (refer to the HomeworldTM manual for a description of all the different ships)

type any additional information in the Info field (such as comments)

select a layer from the Layer drop-down list, if necessary

adjust the ship's Position by typing new x, y and z coordinates in the appropriate fields

adjust the ship's Rotation, if necessary

adjust the ship's Scale, if necessary (as a visual aid only)

click OK



The Size field is linked the Scale field. Changing information in one will automatically update the other, after a ship is visible in MissionMan. The default sizes (100% scale) are preset and while you can scale ships in MissionMan, ships will always appear at default sizes when you play HomeworldTM



Hint

You can cut/copy/paste ships and resources in MissionMan, but these operations do not affect the placement of the objects. To work faster, use the duplicate operation which creates new ships and resources based on the currently selected object by placing them at the position of mouse cursor in the Top, Side and Front views.



Ship Attributes

Like MissionSpheres, Ships also have default attributes that can be modified:

NumShips (refers to the number of ships, one by default; this allows you to have as many identical ships in one location as you want without cluttering the views)

Formation (refers to the formation used to attack, null by default; it can be changed to Delta, Delta 3D, Parade, Sphere, Wall, or UseAsMothership)



Change a Ship’s Attributes

To easily modify an object’s attributes:

click on the expand box (+) beside the appropriate object in the tree view

right-click on the appropriate attribute in the tree view to show a menu that includes Attribute Properties, Delete Attribute, Cut Attribute and  Copy Attribute

click on Attribute Properties and type/select a value from the Value drop down list at the top of the attribute properties dialog box

click OK



Step Three – Defining a ResourceSphere



The ResourceSphere contains resources such as asteroid, dust/gas clouds and nebulae. Players will compete for the resources to build additional ships.

Add New Resources:

position the placement cursor in the Top, Side and Front views to the desired position in the universe

select the appropriate ResourceSphere in the tree view

click on Edit and click on New in the menu

select Asteroid, DustCloud, GasCloud or Nebula from the Type drop-down list at the top of the object properties dialog box

select the appropriate shape for the resource object from the Name drop-down list

type any additional information in the Info field (such as comments)

select a layer from the Layer drop-down list, if necessary

adjust the resource's Position by typing new x, y and z coordinates in the appropriate field

adjust the resource's Rotation, if necessary

adjust the resource's Scale, if necessary

click OK



Unlike ships, resource sizes can be changed. The size of a resource in HomeworldTM matches the size set in MissionMan.



Resource Attributes

Like ResourceSpheres, resources also have default attributes that can be modified.

Change a Resource’s Attributes

To easily modify an object’s attributes:

click on the expand box (+) beside the appropriate object in the tree view

right-click on the appropriate attribute in the tree view to show a menu that includes Attribute Properties, Delete Attribute, Cut Attribute and  Copy Attribute

click on Attribute Properties and type/select a value from the Value drop down list at the top of the attribute properties dialog box

click OK



Asteroids and Dustcouds

Asteroids and Dustclouds have two main attributes:

distribution (refers to the layout of the resource fragments within resource object)

numResources (refers to the number the resource fragments within the resource object)



The number of resource fragments for Asteroid indicates how many resource units are available to the players:

0 – 0 resource units

1 – 25 resource units

2 – 40 resource units

3 – 100 resource units

4 – 400 resource units



Dustclouds are similarly defined:

0 – 0 resource units

1 – 108 resource units

2 – 250 resource units

3 – 700 resource units



Nebulas

Nebulas have three main attributes:

distribution (see Asteroids above)

numTendrils (refers to the length of the tendril)

numChunks (refers to the number of chunks in the nebula)



Hints/Alternative Commands



Double-clicking on an object/attributes shows the object/attribute properties dialog box.



Right clicking on an object/attribute shows a context-sensitive menu for that object/attribute.



Pressing Enter shows the object/attribute properties dialog box for the currently selected objects/attributes.



Pressing Delete deletes the currently selected objects/attributes
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